Applicant users are experiencing a problem connecting to TransUnion
Incident Report for Intellirent Status Center
Resolved
The TransUnion identity verification delay has been resolved. Applications that have been impacted should log back into their account to complete the TransUnion IDV. We thank you for your patience!
Posted Dec 12, 2022 - 08:14 PST
Monitoring
Applicants are being notified on an individual basis if they have been impacted with updates and next steps. The application form and attached documents are NOT impacted; an agent user is able to see all renter submitted information while waiting on the TransUnion Identity Verification.

No data has been lost and all submissions are secure.
Posted Dec 10, 2022 - 12:49 PST
Identified
Our development team identified the issue and we are working diligently to resolve concerns. Our support team will be handling user inquiries and next steps for applicants that have been impacted directly.

No data has been lost and all submissions are secure.

We thank you for your patience.
Posted Dec 10, 2022 - 09:40 PST
Investigating
Some applicant users are having a problem connecting to TransUnion's Identity Verification. We’re aware of the issue and are working on it urgently. If required, impacted users will be notified with steps to rectify the issue.

Please know our teams are working hard to get everything up and running. We sincerely apologize for the inconvenience and look forward to providing updates.
Posted Dec 09, 2022 - 17:42 PST
This incident affected: Application to Rent and TransUnion.